それなりブログ

とあるWebエンジニアのそれなりのブログ、JavaScript/Node.js/Python/PHP/ゲーム作成 など

さくらにRailsを入れる

~ さくらインターネット共有サーバでRoR計画 – 第2章 ~

生Rubyが入ったので、お次はRailsだっ!

まずは、”gem”という
PHPで言えばpearコマンドに相当するようなパッケージ管理コマンドのインストールをする。

cd $HOME/local/src
wget http://rubyforge.org/frs/download.php/17190/rubygems-0.9.2.tgz
tar xzf rubygems-0.9.2.tgz
cd rubygems-0.9.2
ruby setup.rb

入ったっぽい。

さて、次はRailsのインストール

gem install rails --include-dependencies

と、このコマンドを打つと

Bulk updating Gem source index for: http://gems.rubyforge.org
ERROR:  While executing gem ... (Gem::GemNotFoundException)
Could not find rails (> 0) in any repository

あれ・・・?エラーになった??
おかしいな、そういう流れ(?)じゃないのに。

適当にエラーメッセージでググるけど、イマイチ見つからない。
サーバの調子でも悪かったかなと、同じコマンドでもう一回打つと

Bulk updating Gem source index for: http://gems.rubyforge.org
Successfully installed rails-1.2.3
Successfully installed rake-0.7.2
Successfully installed activesupport-1.4.2
Successfully installed activerecord-1.15.3
Successfully installed actionpack-1.13.3
Successfully installed actionmailer-1.3.3
Successfully installed actionwebservice-1.2.3
Installing ri documentation for rake-0.7.2...
Installing ri documentation for activesupport-1.4.2...
Installing ri documentation for activerecord-1.15.3...
Installing ri documentation for actionpack-1.13.3...
Installing ri documentation for actionmailer-1.3.3...
Installing ri documentation for actionwebservice-1.2.3...
Installing RDoc documentation for rake-0.7.2...
Installing RDoc documentation for activesupport-1.4.2...
Installing RDoc documentation for activerecord-1.15.3...
Installing RDoc documentation for actionpack-1.13.3...
Installing RDoc documentation for actionmailer-1.3.3...
Installing RDoc documentation for actionwebservice-1.2.3...

上手く行った。
・・・いいのかこれ?

後で調査して、それらしい対応を掲載してくれているサイトを発見しました。
そのサイト様によると、リモートインストールの場合は

gem install --remote rails --include-dependencies

と、”–remote”オプションをつければよかったとのこと。

次はMySQLドライバのインストール
また、微妙に怪しいので出力も含めて記載します。

gem install mysql
Bulk updating Gem source index for: http://gems.rubyforge.org
Select which gem to install for your platform (i386-freebsd6.1)
1. mysql 2.7.3 (mswin32)
2. mysql 2.7.1 (mswin32)
3. mysql 2.7 (ruby)
4. mysql 2.6 (ruby)
5. Skip this gem
6. Cancel installation
> 3
Building native extensions.  This could take a while...
Successfully installed mysql-2.7

大丈夫っぽい。

これで必要なものは入ったはずなので
後は、実際に動作確認だと。

長くなったので、続く・・・

今回の参考サイトは色々ありましたけど、一番見たのはココです。


Categories

Archives