それなりブログ

とあるWebエンジニアのそれなりのブログ、JavaScript/Node.js/Python/PHP/ゲーム作成 など

bundleコマンドでCould not find bundlerエラー

Bundlerは、前にRedmineを入れる際に使った時は動いていたのですが
今回Jasmineを入れようと使ったら以下のようなエラーが出てきてしまい・・・

$ bundle init
/usr/lib/ruby/site_ruby/1.8/rubygems/dependency.rb:247:in `to_specs': Could not find bundler (>= 0) amongst [a
ddressable-2.3.2, childprocess-0.3.6, chunky_png-1.2.6, compass-0.12.2, diff-lcs-1.1.3, ffi-1.2.0, fssm-0.2.9,
 jasmine-1.3.1, jasmine-core-1.3.1, json-1.7.5, libwebsocket-0.1.7.1, multi_json-1.4.0, rack-1.4.1, rake-10.0.
2, rspec-2.12.0, rspec-core-2.12.1, rspec-expectations-2.12.0, rspec-mocks-2.12.0, rubyzip-0.9.9, sass-3.2.3,
selenium-webdriver-2.26.0, websocket-1.0.4] (Gem::LoadError)
        from /usr/lib/ruby/site_ruby/1.8/rubygems/dependency.rb:256:in `to_spec'
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:1231:in `gem'
        from /usr/bin/bundle:18

途方に暮れてアレコレしていました

そして結局は、もう一度

# gem install bundler

をしたら、直ったという話です

環境は、さくらVPSのCentOS6のyumで入るrubyです

不明点

ググると、この記事のように
“Could not find bundler” error

「インストールしているなら bundle update で直るんじゃない? HAHA」

という回答はみつかったのですが
再度 gem install しろってのは見つかりませんでした
(ちなみに bundle update を打つと、init と同じエラーが出て動かなかった)

まぁ、わからないけどいいやってことで。



コメントを残す

メールアドレスが公開されることはありません。

Categories

Archives